1С 8.3 БСП ДобавитьЗадание - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ДобавитьЗадание

Данные > Примеры кода 1С > 1С 8.3 БСП > Регламентные задания
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ДобавитьЗадание. Добавляет новое задание в очередь или как регламентное.
Примера кода от rayastar
Результат = РегламентныеЗаданияСервер.ДобавитьЗадание(Параметры);

//
&НаСервере
Процедура ВключитьЗадание(Организация)

   УстановитьПривилегированныйРежим(Истина);

   Отбор = Новый Структура();
   Отбор.Вставить("Метаданные", "ОтправкаОтчетностиВБанк");
   Задания = РегламентныеЗаданияСервер.НайтиЗадания(Отбор);

   ТребуетсяСоздатьЗадание = Истина;

   Если Задания.Количество() = 0 Тогда
       ТребуетсяСоздатьЗадание = Ложь;
   КонецЕсли;

   Если ТребуетсяСоздатьЗадание Тогда
       ПараметрыЗадания = Новый Структура;
       ПараметрыЗадания.Вставить("Метаданные", Метаданные.РегламентныеЗадания.ОтправкаОтчетностиВБанк);

       ПараметрыЗадания.Вставить("Параметры", ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(Организация));
       ПараметрыЗадания.Вставить("Расписание", РасписаниеОтправки());
       НаименованиеЗадания = СтрШаблон(НСтр("ru = 'Отправка отчетности в Сбербанк от %1'"), Организация);
       ПараметрыЗадания.Вставить("Наименование", НаименованиеЗадания);

       ПараметрыЗадания.Вставить("ИнтервалПовтораПриАварийномЗавершении",    1200);
       ПараметрыЗадания.Вставить("КоличествоПовторовПриАварийномЗавершении", 3);
       ПараметрыЗадания.Вставить("Использование", Истина);

       РегламентныеЗаданияСервер.ДобавитьЗадание(ПараметрыЗадания);

   КонецЕсли;

   УстановитьПривилегированныйРежим(Ложь);

КонецПроцедуры;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 13.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому