1С 8.3 БСП ДобавитьОшибкуПользователю - Программист 1С Минск. Автоматизация бизнеса.

Перейти к контенту

1С 8.3 БСП ДобавитьОшибкуПользователю

Данные > Примеры кода 1С > 1С 8.3 БСП > Оповещения пользователя
Реклама:
Перейти в раздел примеры кода 1С 8.3:
  • 1С 8.3 БСП
1С 8.3 БСП ДобавитьОшибкуПользователю. Добавляет в список ошибок новую ошибку пользователя для дальнейшей отправки с помощью процедуры СообщитьОшибкиПользователю().
Примера кода от rayastar
ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки, ПолеОшибки, ТекстДляОднойОшибки, ГруппаОшибок, НомерСтроки, ТекстДляНесколькихОшибок, ИндексСтроки)

Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)

   Ошибки = Неопределено;

   // Проверка использования родителя.
   Если Родитель = Справочники.ГруппыПользователей.ВсеПользователи Тогда
       ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки,
"Объект.Родитель",
       НСтр("ru = 'Предопределенная группа ""Все пользователи"" не может быть родителем.'"),
"");
   КонецЕсли;

   // Проверка заполнения значения.
   Если НЕ ЗначениеЗаполнено(ТекущаяСтрока.Пользователь) Тогда
       ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки,
"Объект.Состав[%1].Пользователь",
       НСтр("ru = 'Пользователь не выбран.'"),
"Объект.Состав",
       НомерСтроки,
       НСтр("ru = 'Пользователь в строке %1 не выбран.'"));
       Продолжить;
   КонецЕсли;

   // Проверка наличия повторяющихся значений.
   НайденныеЗначения = Состав.НайтиСтроки(Новый Структура("Пользователь", ТекущаяСтрока.Пользователь));
   Если НайденныеЗначения.Количество() > 1 Тогда
       ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки,
"Объект.Состав[%1].Пользователь",
       НСтр("ru = 'Пользователь повторяется.'"),
"Объект.Состав",
       НомерСтроки,
       НСтр("ru = 'Пользователь в строке %1 повторяется.'"));
   КонецЕсли;

   ОбщегоНазначенияКлиентСервер.СообщитьОшибкиПользователю(Ошибки, Отказ);

КонецПроцедуры ;
// Автор библиотеки: ООО "1С-Софт". Все права защищены © 2021
// Типовая конфигурация Библиотека стандартных подсистем (далее - БСП)
// Код БСП распространяется по лицензии Attribution 4.0 International (CC BY 4.0):
// ссылка на лицензию: https://creativecommons.org/licenses/by/4.0/legalcode
Поиск кода
0
комментарии
____________________
Copyright by 1Cnik.by©, «Программист 1С в г.Минске», 13.06.2021
Перепечатка текста и фотографий разрешена при наличии прямой ссылки на источник
Назад к содержимому